[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

guile's #'system call under cygwin/xemacs?

From: Rick Taube
Subject: guile's #'system call under cygwin/xemacs?
Date: Fri, 28 Mar 2003 09:25:32 -0600

I am running Guile 1.6.1 in several different environments: Linux/OSX/Cygwin. Its great. In each case I am working with guile as a subprocess of Xemacs 21.4.11. Sofar everything seems well-behaved in both Linux and OSX, however under Cygwin/Xemacs I cannot get Guile's 'system' call to work. It does work if I run Guile from the Cygwin shell. I cannot figure out what pathname to pass to #'system to run 'uname' or any other command from a subprocess of Xemacs. Ive tried various and sundry incantations of "/cygdrive/c/cygwin/bin/uname" and "/usr/bin/uname" and so on but it never finds it.

Question #1: Can someone tell how I get the 'system' procedure to work under Xeamcs/cygwin? (One possible source of confusion: in the Cygwin shell "which uname" reports /usr/bin/uname but the "uname.exe" file is actaually under "C:\cygwin\bin\uname.exe" ditto with the guile.exe itself.)

Question #2: I need access to the 'uname' command to figure out what OS im running under -- is there a better way to do this??)

Question #3 (and I know im pushing my luck here but what the heck...) : My software system computes MIDI files which I would like to automatically play after they are generated on the PC. There is is a window's Media player sitting in
        C:\Program Files\Windows Media Player\mplayer2.exe
that is very tempting -- How can I exec this program from inside Guile/Xemacs ?

thanks for any help

Rick Taube
Associate Professor, Composition/Theory
School of Music
University of Illinois
Urbana, IL 61821 USA
net: address@hidden
fax: 217 244 8319
vox: 217 244 2684

reply via email to

[Prev in Thread] Current Thread [Next in Thread]