[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug with #:use-syntax?

From: Clinton Ebadi
Subject: Bug with #:use-syntax?
Date: Wed, 23 Jun 2004 05:03:50 -0400

Using my Guile-Web xhtml generation module
[], if I (use-modules
(web html)) without first doing a (use-syntax (ice-9 syncase)) all
content following the use-modules is not seen by the web browser if
running as a CGI. 

I tried figuring out what was causing this to happen (I seem to be
unable to sleep tonight) and as soon as I put a (use-syntax (ice-9
syncase)) before the use-modules everything worked.

Attached is test0.cgi which shows the bug;
if you remove the
use-syntax it stops working. The /really/ weird part is that the output
is identical both times which makes no sense...(I figured at first that
EOF was being inserted but a quick look with hexedit doesn't show any
nul or eof characters in the output either time).

AIM:unknownlamer IRC:address@hidden
I use Free Software because I value freedom over features.

Attachment: test0.cgi
Description: application/cgi

Attachment: test0.cgi
Description: application/cgi

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]