[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ./guile-config : permission denied

From: Jon Wilson
Subject: Re: ./guile-config : permission denied
Date: Fri, 01 Dec 2006 23:48:23 -0600
User-agent: Thunderbird (X11/20061115)

Hi Gopi,
Could you make sure that /usr/local/bin is in your PATH?  Try

echo $PATH

You should get a colon-separated list of directories. If /usr/local/bin is not there, then we have a problem. I shouldn't think this is root problem, however, as it doesn't say it cannot find guile-config, but that permission is denied.

Maybe the permissions on /usr/local/bin or /usr/local are wrong. Could you check the permissions on those directories as well? (use ls -ld so you get the directory instead of its contents)

Try running


directly yourself.  See if you can do that without running the script.

Beyond that, I'm stumped.  Anyone else got any ideas?


Gopi kumaran wrote:
Hi Jon
Let me tell you that guile-config is in /usr/local/bin folder.Actually it is found in guile-1.8.1 folder.I copied it to /usr/local/bin folder as i thought it will check in that folder only (for sdl-config it checked in /usr/local/bin only).Then wehn i run ./configure same problem guile-config permission denied.i checked the permisions ls - l /usr/local/bin/guile-config it says
-rwxr-xr-x 1 root wheel 9104 dec 2 15:14 guile-config
what to do now?is it because that i copied the folder to that bin folder?
help me

*/Jon Wilson <address@hidden>/* wrote:

    Hi Gopi,
    Are you sure that the execute permissions are set for the
    executable? Check this with ls -l /path/to/guile-config . It should
    look something like

    $ ls -l /usr/local/bin/guile-config
    -rwxr-xr-x 1 root root 9110 2006-11-30 10:00

    The gibberish at the beginning of the line is the permissions. r is
    read, w is write, x is execute. The first rwx is for the owner of the
    file (root in this case), the second r-x is for any user in the group
    (root) that owns the file, and the third r-x is for all other users.
    That initial - is for a few special things, like marking directories.

    If you lack the x on the third set of permissions, then most users
    not be able to execute guile-config, and in fact it will fail with
    the error message you received. If you lack the x on all three
    sets of
    permissions, then nobody (yes not even root) will be able to execute

    You can change the permissions with chmod (1). Try

    $ chmod a+x /path/to/guile-config

    This will set the execute bit for owner, group, and others, that
    is, for
    all three permissions categories. It will leave the read and write


    Gopi kumaran wrote:
    > when i run ./configure in guile-1.8.1 it stops by saying
    > checking for guile...guile-config:permission denied
    > configure:cannot find guile-config;is Guile installed?
    > wht to do?I went to /usr/local/bin(i assume that it will check
    in this
    > folder).i tried to run ./guile-config in
    > folder it says
    > ./guile-config:permission denied
    > I changed to su and then tried but still same problem
    > Any help
    > regards
    > gopi
    > Everyone is raving about the all-new Yahoo! Mail beta.
    > _______________________________________________
    > Guile-user mailing list
    > address@hidden

Want to start your own business? Learn how on Yahoo! Small Business. <*>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]