[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building shared libs (DLL) under Cygwin (1.8.4)

From: Cesar Strauss
Subject: Re: Building shared libs (DLL) under Cygwin (1.8.4)
Date: Thu, 01 May 2008 15:47:03 -0300
User-agent: Thunderbird (Windows/20080213)

Neil Jerram wrote:
"Aaron Turner" <address@hidden> writes:

I'm trying to rebuild Guile 1.8.4 under Cygwin (latest stable) because
the Cygwin packages seem to have some serious problems (I've been told
it was built with the wrong version of gcc).  Everything seems ok
(configure && make report no errors), but when it's all said and done,
all I get is a static library. [snip]

Please try this:

make clean
libtoolize --copy --force
make install

It seems the particular version of libtool included in guile 1.8.4 is somewhat broken on mingw/cygwin. The above worked for me on both platforms.

I would suggest working with the Cygwin people on this.  They are more
likely to be familiar with this kind of issue (which probably comes
from how the autotools work on Cygwin), and if there's a problem with
the current Guile in Cygwin, it would be much better to fix that for
all Cygwin users.

I agree, that would be best.

(FWIW, when I last updated a couple of weeks ago, the Cygwin Guile
version was 1.8.2.  I've been using that successfully and haven't seen
any critical problems.  I did see a problem with open-input-pipe
hanging, but worked around that by writing to a temporary file instead
and then re-reading from that file.)

As far as I could follow the discussion, it seems the Autogen tool used to crash frequently, but worked when Guile was compiled from source.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]