[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building shared libs (DLL) under Cygwin (1.8.4)

From: Aaron Turner
Subject: Re: Building shared libs (DLL) under Cygwin (1.8.4)
Date: Thu, 1 May 2008 14:53:39 -0700

On Thu, May 1, 2008 at 11:47 AM, Cesar Strauss <address@hidden> wrote:
> Neil Jerram wrote:
> >
> > "Aaron Turner" <address@hidden> writes:
> >
> >
> > >
> > > I'm trying to rebuild Guile 1.8.4 under Cygwin (latest stable) because
> > > the Cygwin packages seem to have some serious problems (I've been told
> > > it was built with the wrong version of gcc).  Everything seems ok
> > > (configure && make report no errors), but when it's all said and done,
> > > all I get is a static library. [snip]
> > >
> > >
> >
>  Please try this:
>  make clean
>  libtoolize --copy --force
>  ./configure
>  make
>  make install
>  It seems the particular version of libtool included in guile 1.8.4 is
> somewhat broken on mingw/cygwin. The above worked for me on both platforms.

Yep!  That worked! Well mostly... 'guile-config link' doesn't return
the correct string (-L/usr/local/lib is AFTER -lguile) but that's
easily fixed with a little shell script magic.

> > I would suggest working with the Cygwin people on this.  They are more
> > likely to be familiar with this kind of issue (which probably comes
> > from how the autotools work on Cygwin), and if there's a problem with
> > the current Guile in Cygwin, it would be much better to fix that for
> > all Cygwin users.
> >
>  I agree, that would be best.

I'll see if I can ping the maintainer.

> > (FWIW, when I last updated a couple of weeks ago, the Cygwin Guile
> > version was 1.8.2.  I've been using that successfully and haven't seen
> > any critical problems.  I did see a problem with open-input-pipe
> > hanging, but worked around that by writing to a temporary file instead
> > and then re-reading from that file.)
> >

I'm still having problems with the lastest version.  I've been told
that it was due to the Cygwin Guile using a different version of gcc
then what is shipped with Cygwin.   No idea if that's true.

>  As far as I could follow the discussion, it seems the Autogen tool used to
> crash frequently, but worked when Guile was compiled from source.

Yep, that's what I've been told.  Limited testing so far seems to
indicate this does fix the problem (autogen isn't crashing anymore,
except for using it with pipes: 'autogen -v | echo' for example).


Aaron Turner - Pcap editing & replay tools for Unix
They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety. -- Benjamin Franklin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]