[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing SLIB 3b1 with Guile 1.8.6 (to work with Gnucash 2.8.8) [S

From: Tom Browder
Subject: Re: Installing SLIB 3b1 with Guile 1.8.6 (to work with Gnucash 2.8.8) [SOLVED]
Date: Thu, 29 Jan 2009 10:05:33 -0600

On Thu, Jan 29, 2009 at 7:33 AM, Ludovic Courtès <address@hidden> wrote:

Hi, Ludo', thanks for the response.

> Tom Browder <address@hidden> writes:
>> [Note that instructions need to be updated to work with slib 3b1; note also
>> that the link to the SLIB installation is broken.]
> IIUC, the only differences is that you used .../guile/site instead of
> ../guile/1.8, and that you removed the reference to
> $SCHEME_LIBRARY_PATH, is this correct?
> Note of these is supposed to make any difference, from which I conclude
> the instructions in Guile's manual are already correct.  :-)

Well, the instructions I removed were ones I tried and they didn't
work, so I don't think they should go in the manual.

>> 6.1.1 SLIB installation
>> The following procedure works, e.g., with SLIB version 3b1 (see SLIB
>> installation):
> The important point with this sentence is that SLIB is third-party
> software, so it's the section of the SLIB manual referenced here that
> has the last word anyway.

Its instructions don't work, either.

>> Notice also that the directory /usr/local/share/guile/site was not
>> produced during the guile installation
> To me more precise, it's $datarootdir/guile/site and
> $datarootdir/guile/1.8 that are produced.  So if you choose
> $datarootdir_!=_/usr/local/share, then no, that directory is not
> created---but it's not in Guile's `%load-path' either.

Not correct for guile 1.8.6, I used the defaults,
/usr/local/share/guile/site was not produced.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]