[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building guile 1.8.6 on Tru64 5.1b

From: Didier Godefroy
Subject: Building guile 1.8.6 on Tru64 5.1b
Date: Sat, 18 Apr 2009 22:23:56 +0200
User-agent: Microsoft-Entourage/

Hello all,

I saw in the last update that building issues on tru64 were being fixed, but
I still have some myself.
I'm building now 1.8.6 and I tried using gcc and tru64 cc without success:

libtool: compile:  gcc -pthread -DHAVE_CONFIG_H -I.. -I.. -I..
-I/opt/TWWfsw/libgmp41/include -I/usr/local/readline/include
-I/usr/local/include -I/opt/TWWfsw/libgmp41/include
-I/usr/local/readline/include -I/usr/local/include -D_REENTRANT -O2 -g -Wall
-Wmissing-prototypes -Werror -MT libguile_la-gc_os_dep.lo -MD -MP -MF
.deps/libguile_la-gc_os_dep.Tpo -c gc_os_dep.c  -DPIC -o
cc1: warnings being treated as errors
gc_os_dep.c:1130: warning: type defaults to 'int' in declaration of '_end'
gc_os_dep.c: In function 'scm_get_stack_base':
gc_os_dep.c:1916: warning: comparison of distinct pointer types lacks a cast
gmake[3]: *** [libguile_la-gc_os_dep.lo] Error 1

The error isn't the same when using cc instead of gcc, but it seems pthread
In the previous 1.8.5 version which I could never build successfully, I was
using a cflag -DSCM_DEBUG_TYPING_STRICTNESS=0 although I forgot how I was
brought to use it, it's been a while since I tried building 1.8.5
I didn't use this flag on 1.8.6 this time.
I was googling about this error and found nothing useful to help me,
although I tried adding -fno-strict-aliasing to the cflags, but that too
didn't help.
I'm no C programmer, so I don't want to alter things I don't know enough
about. I need some help to get this build to work.


Didier Godefroy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]