[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building guile 1.8.6 on Tru64 5.1b

From: Didier Godefroy
Subject: Re: Building guile 1.8.6 on Tru64 5.1b
Date: Sat, 25 Apr 2009 16:19:35 +0200
User-agent: Microsoft-Entourage/

on 4/25/09 3:24 PM, Mike Gran at address@hidden uttered the following:

> On Sat, 2009-04-25 at 14:29 +0200, Didier Godefroy wrote:
>> I simply removed that @LTLIBINTL@ from that Makefile and re-ran the make to
>> allow the build to be successful then I ran the tests, and the numbers.test
>> does fail. However I still went ahead with the install, hoping it wouldn't
>> bother my build of autogen. I tried with autogen 5.5.7 and now 5.9.7 and get
>> the same errors of unresolved symbols scm_makstr and gh_eval_str which seem
>> to be guile related. I couldn't find anything useful to fix this while
>> googling, so I'm back to the guile list.

> Those two functions do exist in Guile 1.8.6, but, they may not get built
> in if you configured with the --disable-deprecated option.
> So, if you've been building guile with ./configure --disable-deprecated,
> then that is your problem.  If that isn't it, then you could try
> explicitly enabling them by using ./configure --enable-deprecated.

That worked!!! Geez! That was so simple and I found no such info by
googling. Hopefully this time being on the mailing list someone with this
same issue will find that info.

One small detail though, the detected version of guile is 1.4 but what I
built should be showing something like 1.8.6 right?

Trying to build autogen again now, the configure finally succeeded.

Didier Godefroy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]