[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [r6rs] abusive request for help on "unbound variable" error

From: Andreas Rottmann
Subject: Re: [r6rs] abusive request for help on "unbound variable" error
Date: Sun, 21 Nov 2010 23:12:29 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

Marco Maggi <address@hidden> writes:

> "Andy Wingo" wrote:
>>On Thu 18 Nov 2010 22:25, Marco Maggi <address@hidden> writes:
>>>   With      Guile's      master      branch      checkout
>>> 8d10ccae79ff46f0ebea92ba36acfaebafba8d86       on      an
>>> i686-pc-linux-gnu I get the following error:
>> Glad you found your problem in other mails.
> I  have  not.  I  was  wrong  regarding  bindings not  being
> re-exported (I forgot what my local scripting infrastructure
> did);  but I  still get  the "unbound  variable"  error from
> Guile.
>   The   only   thing   I   can  guess   (after   trying   to
> comment/uncomment random forms) is that it is a problem with
> the expander possibly in its interaction with compiled code,
> because all the other  R6RS implementations work fine.  Also
> I have found this: when  I run the test with "--autocompile"
> (starting with a clean cache) I get the error:
> GUILE_LOAD_PATH=. guile -l guile-r6rs-setup.scm --autocompile -s 
> ./tests/test-annotated-types.sps
> ;;; note: autocompilation is enabled, set GUILE_AUTO_COMPILE=0
> ;;;       or pass the --no-autocompile argument to disable.
> ;;; compiling guile-r6rs-setup.scm
> [...]
> ;;; WARNING: compilation of ./tests/test-annotated-types.sps failed:
> ;;; key vm-error, throw_args (vm-run "VM: Unbound variable: ~s" (#<variable 
> 851b5e8 value: #<undefined>>))
> guile: uncaught throw to vm-error: (vm-run "VM: Unbound variable: ~s" 
> (#<variable 851b5e8 value: #<undefined>>))
> make: *** [gtest] Error 1
Yep, that's the unfortunatly quite non-descriptive error you'll get when
a module exports a binding it does not define.

> but  when  running  with  "--no-autocompile" (with  a  clean
> cache) I get:
> ERROR: Unbound variable: assert
> make: *** [gtest] Error 1
> I do use ASSERT in the code, but I do no strange things with
> its binding.   Unfortunately I have  no time to dive  in the
> internals of Scheme implementations.
Indeed `assert' is missing from Guile ATM, but I've submitted a patch a
while ago that fixes that (among other things):


I hope that someone gives that patch a review soon (*hint* *hint*)...

Regards, Rotty
Andreas Rottmann -- <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]