[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Program Start-Up Error: Unable to find file "ice-9/boot-9.scm"

From: Amandeep Singh
Subject: Program Start-Up Error: Unable to find file "ice-9/boot-9.scm"
Date: Mon, 8 Sep 2014 21:47:31 -0700

Operating System: Windows 8.1
Cygwin Version: Latest version, as of Sept. 9, 2014. 
Guile Version: 1.8

My overall goal is to install a program called "MIT Photonics Band (MPB)" ( on Windows 8.1 using Cygwin. I am a new user, as I started using Cygwin a few days ago. I was able to install all required packages successfully after some troubleshooting. Eventually, I installed the MPB program using the generic ./configure, make, make install commands with slight modifications. All of this appeared to be successful.

The Problem:
When I try to run the executable program, I get the following error:
ERROR: In procedure primitive-load-path:
ERROR: Unable to find file "ice-9/boot-9.scm" in load path

Attempt At Solution:
The following is a page of the MPB installation manual:
It appears to address my issue. Note that it mentions LIBDIR and foobar. For my operating system, foobar is PATH. The LIBDIR, however, I do not know explicitly because my "make install" output did not indicate it, as the manual suggests it should have. Anyhow, I found the location of ice-9/boot-9.scm through a computer search and its directory happens to be here:
Hence, I ran the following command (again, for a Windows 8.1 operating system) in bash:
$ export PATH="/usr/share/guile/1.8/ice-9:$PATH"

However, note that when I run $PATH, I get this message:
-bash: /usr/share/guile/1.8/ice-9:/usr/local/bin:/usr/bin:/cygdrive/c/Program: No such file or directory

I also tried:
$ export GUILE_LOAD_PATH="/usr/share/guile/1.8/ice-9:$GUILE_LOAD_PATH"

That yielded:
-bash: /usr/share/guile/1.8/ice-9:: No such file or directory

Furthermore, I tried to copy and paste the "ice-9" folder in various locations for a quick and sloppy solution, but it was to no avail. I searched online for answers as some users have had an issue with the program not finding the ice-9/boot-9.scm file in the past. I could not get my problem solved. 

Please let me know if I need to provide more information. I appreciate the help!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]