[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: --listen option broken on Mac

From: Alex Vong
Subject: Re: --listen option broken on Mac
Date: Mon, 28 Dec 2015 18:44:38 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Matthew Keeter <address@hidden> writes:

> Hi Guile-folks,
> I’m having trouble with the --listen option on Guile 2.0.11, Mac OS 10.9.5.
> I start up one REPL with “guile --listen”, then connect with “nc localhost 
> 37146”
> The netcat window immediately fills with (repeating over and over):
>     scheme@(guile-user)> While reading expression:
>     ERROR: In procedure fport_fill_input: Resource temporarily unavailable
> When I kill the nc process, the REPL crashes with "fport_write: Broken pipe”
> I’ve tried running this on a Linux VM and it works fine.
> Per discussions on IRC, I tried to run the test suite.  However, the
> test suite failed
> with the message
>     ERROR: In procedure scm-error:
>     ERROR: no code for module (test-suite lib)
I do not use Mac but I think you can try to run `make check' on the
latest master branch.

Test summary on my Debian laptop:

Totals for this test run:
passes:                 41078
failures:               0
unexpected passes:      0
expected failures:      10
unresolved test cases:  14
untested test cases:    1
unsupported test cases: 10
errors:                 0

PASS: check-guile
1 test passed

> Any suggestions on how to proceed?  Can anyone else on a Mac confirm this 
> issue?
> -Matt

reply via email to

[Prev in Thread] Current Thread [Next in Thread]