[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: name an array function

From: Daniel Llorens
Subject: Re: name an array function
Date: Mon, 21 Nov 2016 14:42:58 +0100

On 21 Nov 2016, at 14:24, address@hidden wrote:

> So should "slice" prevail, it'd make sense to "invert" the star
> (array-slice corresponding to array-from* and vice-versa)?

I think it's more important to give the simpler names to the functions that are 
more commonly used. So I would keep the name array-slice* for the function that 
returns #0(a), in spite of logic.

Of course, that's one reason why I don't like array-slice too much!

> Had I to look it up by name without any idea of what to look
> for, I'd never come up with array-from, whereas I'd have a faint
> chance of coming up with array-slice; that said, the most
> ergonomic choice would still be (an extension of) array-ref et
> al. or some close relative.

Yeah, I do see your point.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]