[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: installing older guile version

From: David Kastrup
Subject: Re: installing older guile version
Date: Mon, 13 Nov 2017 16:00:11 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

Christian Alpen <address@hidden> writes:

> Hi everybody,
> I have a problem installing an older guile-version.
> I wanted to install a development-version of lilypond, which quits
> with following error:
> *WARNING: Please consider installing optional programs or files: 
> guile-2.0 < 1.9.0 (installed: 2.0.13)
> ERROR: Please install required programs:  guile-config < 1.9.0
> (installed: 2.0.13) (guile-devel, guile-dev or libguile-dev package)
> libguile (libguile-dev, guile-devel or guile-dev
> package). GUILE-with-rational-bugfix**
> *
> So  I got me an older version guile-1.7.91 (as I couldn't find any
> 1.8, this was the nearest to <1.9.0).

1.8.8 is the latest.  Current compilers and Texinfo might require a few
patches.  I think I remember that someone on this list (Thien-Thi
Nguyen?) maintained his own 1.8 version: it may be that joining forces
with him while Guile-2.x remains unsuitable for use with LilyPond is a
good idea.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]