[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guile-CV: Not a GRAY, RGB nor an RGBA image "sand.tif"

From: Daniele
Subject: Re: Guile-CV: Not a GRAY, RGB nor an RGBA image "sand.tif"
Date: Wed, 6 Dec 2017 08:12:54 +0100

Hi David,
I hadn't tried make check, and in fact it fails on a very similar
error (pp-17-bf.png is right there when is trying to find it and it
opens in an image viewer just fine):

test-impex failed: assert-equal: expected:
(85 95 1)

(0 0 0)

test-features-2: exception in test: (misc-error #f "~A ~S" ("Not a
GRAY, RGB nor an RGBA image"
"/home/daniele/build/guile-cv/doc/images/pp-17-bf.png") #f)

20 run, 2 failed
FAIL: tests/cv.scm
1 of 2 tests failed
Please report to david at altosw dot be
Makefile:368: recipe for target 'check-TESTS' failed
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory '/home/daniele/build/guile-cv/test-suite'
Makefile:491: recipe for target 'check-am' failed
make[1]: *** [check-am] Error 2
make[1]: Leaving directory '/home/daniele/build/guile-cv/test-suite'
Makefile:649: recipe for target 'check-recursive' failed
make: *** [check-recursive] Error 1
address@hidden:~/build/guile-cv$ eog doc/images/pp-17-bf.png

2017-12-05 22:55 GMT+01:00 David Pirotte <address@hidden>:
> Hi Daniele,
>> > Yes: your are not in the right directory wrt guile, and this flename 'does 
>> > not
>> > exists', it does not exists in the directory your are trying to load this 
>> > image,
>> > see:
>> >
>> >         scheme@(guile-user)> (getcwd)
>> >         $5 = "/usr/alto/projects/guile-cv/images"
>> unfortunately that's not the problem, I am in the right directory and
>> the image is there. I still get that error.
> This is impossible :), you think you are in the right directory, but you most
> likely you are not.
> You can try (getcwd), then (system "ls") and compare ...  till you are 
> convinced
> this is the source of your problem (or proved me wrong, then I'll pay you a 
> pack of
> beers :)
>         unless you would have inadvertently replaced the file content with 
> something
>         else then a tif image... I very much doubt but just in case, you can 
> run
>         'file sand.tif' in a terminal and double check... if the file is not 
> a tif
>         file, although it would be in the directory, the same error you be
>         reported ...
> Did you run 'make check' while you built guile-cv? Did all check pass? It 
> checks
> that im-load works fine ...
> David

reply via email to

[Prev in Thread] Current Thread [Next in Thread]