[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Nyacc and guile-nearly-3.0 (progress report)

From: Matt Wette
Subject: Re: Nyacc and guile-nearly-3.0 (progress report)
Date: Mon, 2 Dec 2019 06:28:53 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.2.1

Look at etc/README.  Maybe edit etc/ and rerun as in the README.

I'm building 2.9.5 now but running into errors (ubuntu 18.04):
/bin/bash: line 6: 14657 Segmentation fault      (core dumped) GUILE_AUTO_COMPILE=0 ../meta/build-env guild compile --target="x86_64-pc-linux-gnu" -O1 -Oresolve-primitives -L "/home/mwette/proj/guile/guile-2.9.5/module" -L "/home/mwette/proj/guile/guile-2.9.5/guile-readline" -o "system/vm/linker.go" "../module/system/vm/linker.scm"

On 12/2/19 4:55 AM, address@hidden wrote:
On Mon, Dec 02, 2019 at 10:40:41AM +0100, address@hidden wrote:

to anyone "in the know": is it worth to give nyacc a spin under
Guile nearly-3.0 (i.e. >= 2.9.5)?
Well, I tried, this is a small progress report. First munged
_guile_versions_to_search in nyacc's configure script to contain
2.9.5 (that's what my guile --version says). Configure bails
out with:

   configure: error: found development files for Guile 2.9.5, but 
/usr/local/bin/guile has effective version 3.0

(FWIW, there's an /usr/local/lib/pkgconfig/guile-3.0.pc). Now
setting _guile_versions_to_search in said script bails out with

   checking for Guile version >= 3.0... configure: error: Guile 3.0 required, 
but 2.9.5 found

So it seems my Guile is schizophrenic: under some aspect it
reports 3.0 ("effective" version), under some aspect it's
2.9.5 (--version version, to put some name on it).

I haven't given up yet, though :-)

Cheers & thanks
-- tomás

reply via email to

[Prev in Thread] Current Thread [Next in Thread]