[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Logo proposal

From: Zelphir Kaltstahl
Subject: Re: Logo proposal
Date: Tue, 28 Jan 2020 21:40:44 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.4.1

Hmmm, I tried again and it worked in command line REPL and Geiser.
Weird, I was remembering something did not work. Perhaps it was only
when I needed lambda* or something. Great, I can use it more often again!

On 1/28/20 1:44 AM, Jose A. Ortega Ruiz wrote:
> On Tue, Jan 28 2020, Zelphir Kaltstahl wrote:
>> On 1/27/20 2:03 PM, Marc Chantreux wrote:
>>> hello,
>>> On Mon, Jan 27, 2020 at 12:30:51AM +0100, Arne Babenhauserheide wrote:
>>>> Did you try it?
>>> i never seen λ used in the documentation or code so what i actually
>>> wrote a macro:
>>>     (define-syntax λ
>>>       (syntax-rules ()
>>>         ((λ sign ...)
>>>          (lambda sign ...))))
>>> i just removed it and the code is still working. thanks a lot.
>>> marc
>> The thing is, it does not work in Geiser in Emacs.
> Hmm, it does work for me.  For instance, this simple example
>    (define-module (foo))
>    (define foo (λ () 3))
> in foo.scm does what i expect.  Also using λ directly in the REPL works
> for me.  What behaviour are you observing instead?  Could it be that
> you're not using UTF-8 as your encoding?
> Cheers,
> jao

reply via email to

[Prev in Thread] Current Thread [Next in Thread]