guile-user
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Naming conventions


From: Zelphir Kaltstahl
Subject: Re: Naming conventions
Date: Tue, 7 Jul 2020 19:51:55 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Icedove/68.8.0

Hi Simen!

(comments in between)

On 07.07.20 13:05, Simen Endsjø wrote:
>
> Hi, I'm quite new to scheme/lisp and haven't coded in a dynamic
> language in many
> years. I notice there are some naming conventions, but I'm not sure
> how they are
> used/supposed to be used.
>
> - *symbol* :: ? Global scope variable?
> - SYMBOL :: ? Also global scope variable?
> - %symbol :: ? private function?
> - %symbol% :: ? private variable?


I have seen the % being used for objects. For example in the Racket docs
for its GUI library:
https://docs.racket-lang.org/gui/windowing-overview.html#%28part._.Creating_.Windows%29

I am not sure, whether this is a Racket-only thing.


> - symbol* :: ? extended version of function with same name?
> - symbol? :: predicate function returning bool
> - symbol! :: Non-pure/mutating function?- <<symbol>> :: ?
> - <symbol> :: ? As a macro parameter, and symbol will be defined  in
> parent scope..?
> - <<symbol>> :: ?
> - type1->type2 :: convertion from type1 to type2
>
> What does all of these mean? Are some of them
> anti-patterns/deprecated? Are there others?
>
> I also see functions named type-operation and operation-type. Is one
> preferable to the other?


Regards,

Zelphir

-- 
repositories: https://notabug.org/ZelphirKaltstahl




reply via email to

[Prev in Thread] Current Thread [Next in Thread]