[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help installing guile-ncurses

From: Mike Gran
Subject: Re: Help installing guile-ncurses
Date: Sun, 5 Feb 2023 16:20:41 -0800

On Sun, Feb 05, 2023 at 06:44:28PM -0500, paul wisehart wrote:
> Hi!,
> I am pretty new to guile, I am trying to install guile-ncurses.
> I'm on OpenBSD 7.2
> I have installed the guile3 package.
> That's the only guile OS package I see.
> I was able to install guile-json locally, so I am trying to install 
> guile-ncurses
> similarly.
> I installed automake and set:
> export AUTOCONF_VERSION=2.69
> export AUTOMAKE_VERSION=1.16
> (this was also needed to install guile-json)
> I installed libunistring and libtool to get past configure errors.
> Now I can configure and make successfully with:
> ./configure --prefix=/home/wise/guile CC=clang CFLAGS='-I/usr/local/include' 
> LDFLAGS='-L/usr/local/lib'
> This is successful.
> Now I run make.  
> It errors out the first time saying it can't find
> so i:
> cd src/ncurses/.libs/ 
> ln -s

Yeah, around guile 3.0.7, it stopped using libltdl which
would do that version number searching for you.  Now,
all packages that make binary extensions need to be fixed
to make version-less binary extensions.  That's something
guile-ncurses needs to fix for itself.

> now make succeeds.
> Now i run make install, and it errors with:
> mkdir: /usr/local/share/guile/site/3.0/ncurses: Permission denied
> See in my configure I set the prefix ?
> This worked for json, which installed into $HOME/guile/...
> (And i've used it succesfully in guile code)
> Any ideas ?

For guile-ncurses configure, if you add the option
 --with-gnu-filesystem-hierarchy, it will try to be more strict
 on where it installs, so that might help.

Note that you'll probably need to
 set GUILE_LOAD_PATH to point to the code

> Happy to give more info or try things and report back.

Mike Gran

> Thanks!
> --
> Paul

reply via email to

[Prev in Thread] Current Thread [Next in Thread]