[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU G-Golf 0.8.0-rc-3 available for testing

From: David Pirotte
Subject: Re: GNU G-Golf 0.8.0-rc-3 available for testing
Date: Sat, 20 Apr 2024 01:51:58 -0300

Hello Florian,

Before i get to the other points of your email, let me exceptionally
raise the last point first:

        This refers to g-golf-0.8.0-a.1

        Can you re-ensure me and confirm you are using the latest
        version, 0.8.0-rc-3, because a number of critical bugs have
        been fixed on the way to and one in 0.8.0-rc-3 ?

> This is a bug in Guix territory; not your g-golf.

Right -

> I have successfully run gtk-4/hello-world.scm, fully responsive
> ...

Great -
Can you 'permanently' fix the problem, in guix i mean, and 'for all',
or is it something every user has(will have to) to know about and 'do',
for every session?

> drawing-widget.scm continued segfaulting, even during the time when
> hello-world.scm worked.

Hum, it is a short and simple example, however, it uses (it has to)
define-vfunc, and this is very likely where the problem is, we'll see

But for now, if you don't mind, let's focus on all examples but:


All other gtk-4 example should work, under the condition you set to
successfully run the hello-world.scm example

The adw-1 examples should work as well, both the hello-world.scm and the

> ...
> My hope was you knew debugging tricks.  After fruitless debug attempts
> with Guile’s ,trace meta-command, I began attaching GDB to Guile,
> where I then run
> ...

I don't have any debugging 'special' tricks or tips - in debian (you'll
have to adapt for guix ofc):

        sudo apt-get install systemd-coredump

then, when facing such a segfault problem, run the example, which
produces a coredump, then:

        cd /var/lib/systemd/coredump/
        # list the files and grab the id of the last coredump, if
        # more then one ... for example ... 1670341
        # install the missing symbols
        sudo -- sh -c 'rm -f core ; \
            coredumpctl dump 1670341 > core ; \
            find-dbgsym-packages --install core ; \
            rm -f core'

        # get a backtrace
        sudo coredumpctl debug 1670341
        (gdb) bt

> ...
> scheme@(guile-user)> (load 
> "/home/florian/src/g-golf/examples/gtk-4/hello-world.scm")
> scheme@(guile-user)> (main '("guile"))

No big deal, but i usually run using/calling:
        (main '())

> I’m rarely on IRC and prefer asynchronous communication.

Fine, ping me if you do ... (my nick is daviid)

> The Adwaita hello-world fails in the same way as GTK hello-world

It should not,
nor the adw1-demo, under the circumstances that
makes the gtk-4 hello-world running fine that is ...

> thank you for advising me to use Adwaita; I did not know it is a good
> idea to use it over plain GTK).

Welcome -
You definitely should learn and use adwaita ...
and use gtk-4 for what ever is not in adwaita ofc ...

> Thank you for confirming the real error is this

> > (hello-world.scm:12627): GLib-GObject-CRITICAL **: 23:59:51.067:
> > cannot register existing type 'GdkPixbuf'  

I don't think 'it matters', the thing is to understand and solve is why guix is
trying to load more then once (any of) the typelib(s) involved in the
session/example you are 'running' - 

> The warning when not running d-bus

> (guile:3310): Gtk-WARNING **: 17:06:29.832: Unable to acquire session
> bus: Failed to execute child process “dbus-launch” (No such file or
> directory)
> occurs for gnome-calculator as well and is not fatal to it.  Also it,
> strangely, disappeared for g-golf’s hello-world.scm, at the time when
> it worked.

But you should try to solve this, with the help of guix guru ... g-golf
does not depend on dbus, but indirectly, gtk-4 (and or Gio, i can't
recall the full details now) do, to (notably) register the application ...)

Guix g-golf users should be able to assume a zero warning, zero error on
all provided g-golf examples - unless reproducible in other distro ofc.

> There are no per-package services in Guix, so it cannot be guaranteed
> d-bus is running everywhere (and missing d-bus is not fatal).  I did
> try in a Guix System’s GNOME desktop environment and D-Bus and
> something A11Y run there by default.  But the GdkPixbuf error was
> still present.

Caution - the warning that leads to the recommendation to either solve
or set the GTK_A11Y env var has nothing to do with the GdkPixbuf error

> ...
> Now run ./configure [--prefix=/your/prefix] [--with-guile-site]
> $ ./configure --with-guile-site
> configure: error: cannot find install-sh,, or shtool in
> build-aux "."/build-aux

I'll let you solve this with guix wizard(s)
> But the g-golf Guix package does run configure and make check
> successfully after some workarounds.  Their log file is at


The above link doesn't work for me:     502 Bad Gateway


This refers to g-golf-0.8.0-a.1


Attachment: pgprlOzsdMTlb.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]