guix-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

01/01: gnu: guix-daemon: Adjust 'install' phase to latest update.


From: guix-commits
Subject: 01/01: gnu: guix-daemon: Adjust 'install' phase to latest update.
Date: Sun, 25 Nov 2018 11:09:51 -0500 (EST)

civodul pushed a commit to branch master
in repository guix.

commit 0a9d1c5ab713bf525972f651c3cb63570e8c083d
Author: Ludovic Court├Ęs <address@hidden>
Date:   Sun Nov 25 17:08:04 2018 +0100

    gnu: guix-daemon: Adjust 'install' phase to latest update.
    
    Fixes <https://bugs.gnu.org/33496>.
    Reported by Brett Gilio <address@hidden>.
    
    This is a followup to commit 254602cdf884379231793c4d793b25c9ebd6c806.
    
    * gnu/packages/package-management.scm (guix-daemon)[arguments]: In
    'install' phase, remove use of "install-nodist_pkglibexecSCRIPTS"
    target.
---
 gnu/packages/package-management.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/gnu/packages/package-management.scm 
b/gnu/packages/package-management.scm
index d277d81..141d0e5 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -345,8 +345,7 @@ the Nix package manager.")
            (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
                (invoke "make" "install-binPROGRAMS"
-                       "install-nodist_pkglibexecSCRIPTS"
-                       "install-nodist_libexecSCRIPTS") ;guix-authenticate
+                       "install-nodist_pkglibexecSCRIPTS")
 
                ;; We need to tell 'guix-daemon' which 'guix' command to use.
                ;; Here we use a questionable hack where we hard-code root's



reply via email to

[Prev in Thread] Current Thread [Next in Thread]