guix-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

08/12: gnu: polybar: Update to 3.6.3.


From: guix-commits
Subject: 08/12: gnu: polybar: Update to 3.6.3.
Date: Thu, 23 Jun 2022 17:22:36 -0400 (EDT)

civodul pushed a commit to branch master
in repository guix.

commit a5d8630e158718325c7804e8043b92013626158c
Author: John Kehayias <john.kehayias@protonmail.com>
AuthorDate: Tue Jun 21 14:14:08 2022 -0400

    gnu: polybar: Update to 3.6.3.
    
    * gnu/packages/wm.scm (polybar): Update to 3.6.3.
    [phases]: Add patch-config-path for polybar to find its default 
configuration
    file in the store.
    [inputs]: Add libuv, required to build polybar.
    [native-inputs]: Remove python-2, no longer needed.
    
    Signed-off-by: Ludovic Court├Ęs <ludo@gnu.org>
---
 gnu/packages/wm.scm | 20 ++++++++++++++------
 1 file changed, 14 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 35b79919b1..ab97266f72 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1469,19 +1469,29 @@ its size
 (define-public polybar
   (package
     (name "polybar")
-    (version "3.5.7")
+    (version "3.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/polybar/polybar/releases/";
                            "download/" version "/polybar-" version ".tar.gz"))
        (sha256
-        (base32 "1nr386jdlm8qkbdf23w7lyvbfhr362s90f957fawnyi1finhw8bk"))))
+        (base32 "19azx5dpfyfh0pv4q2fcrf4p7a0pc5d13m7lnv3qy8376mbmhmzj"))))
     (build-system cmake-build-system)
     (arguments
      ;; Test is disabled because it requires downloading googletest from the
      ;; Internet.
-     '(#:tests? #f))
+     (list #:tests? #f
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Make polybar find its default configuration file in the
+               ;; store.
+               (add-after 'unpack 'patch-config-path
+                 (lambda _
+                   (substitute* "CMakeLists.txt"
+                     (("/etc") (string-append #$output "/etc")))
+                   (substitute* "src/utils/file.cpp"
+                     (("\"/etc\"") (string-append "\"" #$output 
"/etc\""))))))))
     (inputs
      (list alsa-lib
            cairo
@@ -1489,6 +1499,7 @@ its size
            jsoncpp
            libmpdclient
            libnl
+           libuv
            libxcb
            pulseaudio
            xcb-proto
@@ -1500,9 +1511,6 @@ its size
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python-sphinx" ,python-sphinx) ; for the manual
-       ;; XXX: "python" input must be located after "python-2", or the package
-       ;; fails to build with "missing required python module: xcbgen".
-       ("python-2" ,python-2)           ; lib/xpp depends on python 2
        ("python" ,python)))             ; xcb-proto depends on python 3
     (home-page "https://polybar.github.io/";)
     (synopsis "Fast and easy-to-use status bar")



reply via email to

[Prev in Thread] Current Thread [Next in Thread]