[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Problems with new bash shell under xp

From: Harald Maier
Subject: Re: [h-e-w] Problems with new bash shell under xp
Date: Fri, 19 Dec 2003 18:24:50 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3 (gnu/linux)

Ken Brown <address@hidden> writes:

> I've been using Cygwin bash as my shell in emacs for a long time with
> no problems, under both windows 98 and 2000.  I just bought a new
> computer running xp, installed the current version of Cygwin, and the
> bash shell under emacs refuses to run programs in the background.
> When I type "program name&", nothing visible happens, though the
> windows task manager shows that the program is running.  If I type
> "ps" in the bash shell, the window suddenly opens, but it hangs with
> an hourglass and I have to kill it.  I've tried this with two
> different programs:  gsview32 and yap.
> The problem occurs in both emacs 21.2 and 21.3.  It doesn't happen if
> I just open a bash shell outside of emacs.
> I don't know whether this is related to xp or the new bash.  I could
> try updating cygwin on my older machines to see what happens, but I
> don't want to take a chance on breaking something that works.

I tried it with a just currently updated cygwin under W2K with the
xterm program. The program did only come up if I typed in
'fg'. Otherwise it is elsewhere but not visible. So I assume it's a
general problem. I don't know what to do.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]