[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[h-e-w] url-retrieve support for https on windows

From: Praki Prakash
Subject: [h-e-w] url-retrieve support for https on windows
Date: Mon, 2 Jan 2006 12:25:12 -0800


I am using emacs (GNU Emacs 21.3.1 (i386-mingw-nt5.1.2600) of 2004-03-10 on NYAUMO) on win xp. I also have OpenSSL (0.9.7c 30 Sep 2003). Any attempt to retrieve URLs over SSL just hangs. I also tried the latest OpenSSL 0.9.8.a which didn't make any difference.

I tried the following.

(setq p (start-process "SSL" "SSL" "openssl"))
(with-current-buffer (process-buffer p) (set-buffer-process-coding
-system 'raw-text-dos 'raw-text-dos))
(process-send-string p "s_client -connect\r\n")
(process-send-string p "Authorization: Basic .......==\r\n")
(process-send-string p "GET /atom\r\n")
(process-send-string p "\r\n")
(process-send-string p "\r\n")

At this point, I can see that OpenSSL has successfully negotiated a secure session. It looks as though OpenSSL is waiting for input to send on the socket and emacs is waiting for output from OpenSSL. After some time, OpenSSL says the socket was closed with error 10054 and complains that GET is not a valid command. I peppered the code above with process-accept-output which didn't make any difference.

I think OpenSSL is working correctly in my setup. I can run OpenSSL interactively and retrieve the URL just fine.

Can anybody help me figure out the problem here?

Praki Prakash

reply via email to

[Prev in Thread] Current Thread [Next in Thread]