[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [h-e-w] Emacs won't run

From: Michael Flynn
Subject: RE: [h-e-w] Emacs won't run
Date: Tue, 10 Jan 2006 18:53:59 -0800

Setting these up cured the problem.  I am not sure I understand why though,
because addpm.exe set these values up in the Windows registry from which I
assumed emacs was reading them.  Previously emacs was running fine with no
environment/shell variables set other than PATH.  Anyway, it works now, so
thanks :)

Michael Flynn
408.358.4041  home
408.768.6400  cell

-----Original Message-----
From: Chris McMahan [mailto:address@hidden 
Sent: Tuesday, January 10, 2006 6:27 AM
To: Michael Flynn
Subject: Re: [h-e-w] Emacs won't run

I have the following when I run getenv from my shell:


Might you have one of these set incorrectly?

- Chris

Michael Flynn writes:
>Hi All,
>I had emacs-21.2 installed.  I installed it and ran addpm.exe and it 
>worked just fine for years.  Then I installed emacs-21.3.  I followed 
>the instructions in README and ran addpm.exe.  It too ran ok for years.  
>It ran if I started it from the Windows start menus, and it would run 
>if I started a cygwin bash shell then typed runemacs.
>Recently I decided to remove the directory structure under 
>Now when I try to start emacs I get a message saying it cannot find 
>/cygdrive/d/emacs-21.2/lisp/term/w32-win.el  whatever way I try to 
>start emacs.
>If I create just that file (copied the w32-win.el from the emacs-21.3, 
>but no other files) to see what would happen, but what happens is that 
>emacs does nothing and no error messagews come up.  From task manager I 
>can see tgcmd grab some memory but no new process appears and I can 
>find no trace of emacs having run.
>My PATH environment variable contains /cygdrive/d/emacs-21.3/bin  
>(which is what it was when emacs was working)
>I check the registry and it has
>hkey-local-machine/software/gnu/emacs/emacs-dir is set to emacs-21.3
>I cannot find anything set to /cygdrive/d/emacs-21.2
>I have rerun addpm.exe but nothing changes.
>Any clues anybody?
>Michael Flynn

Chris McMahan | address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]