[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Building Emacs trunk on Windows 7, using MinGW + MSYS

From: Eli Zaretskii
Subject: Re: [h-e-w] Building Emacs trunk on Windows 7, using MinGW + MSYS
Date: Mon, 04 Jul 2011 17:57:51 +0300

> Date: Sun, 3 Jul 2011 16:50:31 +0200
> From: Dani Moncayo <address@hidden>
> I'm trying to build Emacs (the latest trunk version) on my system
> (Windows 7 64-bit). I've tried to follow the instructions in
> "INSTALL.BZR" and "nt/INSTALL", but I still haven't found the way.
> Here's what I've tried:
> 1. I've installed the latest MinGW/MSYS in folder "C:\MinGW".
> 2. I've added "C:\MinGW\bin;C:\MinGW\msys\1.0\bin" to the system PATH.

nt/INSTALL clearly recommends not to use the MSYS shell:

  In addition, using 4NT or TCC as your shell is known to fail the
  build process, at least since 4NT version 3.01.  Use CMD.EXE, the
  default Windows shell, instead.  MSYS sh.exe also appears to cause
  various problems, e.g., it is known to cause failures in commands
  like "cmd /c FOO" in the Makefiles, because it thinks "/c" is a
  Unix-style file name that needs conversion to the Windows format.
  If you have MSYS installed, try "make SHELL=cmd.exe" to force the
  use of cmd.exe instead of the MSYS sh.exe.

> 5. From a console (cmd.exe), I've executed these commands:
>   5.1 cd C:\Emacs\trunk\nt
>   5.2 configure --without-xpm --without-png --without-jpeg
> --without-tiff --without-gif > configure.log 2>&1
>   5.3 make bootstrap > make.log 2>&1
> I'm attaching the output from configure and make commands
> ("configure.log" and "make.log").
> The make command stops after a while.  It seems that a new session of
> cmd.exe has been started, and is waiting for input.  I know this
> because I see two "cmd.exe" processes in the task manager, and also
> the last part of make's output suggests that.

Yes.  You are hitting exactly the problem with the MSYS shell
described above, whereby it doesn't grok "cmd /c":

> cmd /c "fc /b gl-tmp globals.h >nul 2>&1 || cp -f gl-tmp globals.h"

> Do you know what am I doing wrong?

You have MSYS on your PATH.  Remove it.  It is not needed for building

reply via email to

[Prev in Thread] Current Thread [Next in Thread]