[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Building Emacs trunk on Windows 7, using MinGW + MSYS

From: Dani Moncayo
Subject: Re: [h-e-w] Building Emacs trunk on Windows 7, using MinGW + MSYS
Date: Mon, 4 Jul 2011 19:50:41 +0200

On Mon, Jul 4, 2011 at 16:57, Eli Zaretskii <address@hidden> wrote:
>> Date: Sun, 3 Jul 2011 16:50:31 +0200
>> From: Dani Moncayo <address@hidden>
>> I'm trying to build Emacs (the latest trunk version) on my system
>> (Windows 7 64-bit). I've tried to follow the instructions in
>> "INSTALL.BZR" and "nt/INSTALL", but I still haven't found the way.
>> Here's what I've tried:
>> 1. I've installed the latest MinGW/MSYS in folder "C:\MinGW".
>> 2. I've added "C:\MinGW\bin;C:\MinGW\msys\1.0\bin" to the system PATH.
> nt/INSTALL clearly recommends not to use the MSYS shell:
>  In addition, using 4NT or TCC as your shell is known to fail the
>  build process, at least since 4NT version 3.01.  Use CMD.EXE, the
>  default Windows shell, instead.  MSYS sh.exe also appears to cause
>  various problems, e.g., it is known to cause failures in commands
>  like "cmd /c FOO" in the Makefiles, because it thinks "/c" is a
>  Unix-style file name that needs conversion to the Windows format.
>  If you have MSYS installed, try "make SHELL=cmd.exe" to force the
>  use of cmd.exe instead of the MSYS sh.exe.

Yes, I read that paragraph.  But I had to add the
"C:\MinGW\msys\1.0\bin" part to the system PATH because not doing so
would mean that "cp.exe" and other utilities required by make would be
missing.  See below:

>> Do you know what am I doing wrong?
> You have MSYS on your PATH.  Remove it.  It is not needed for building
> Emacs.

I've removed that directory from my PATH, and now the configure command says:

  Checking for 'cp'...
  'cp' is not recognized as an internal or external command,
  operable program or batch file.
  You need 'cp' (the Unix file copy program) to build Emacs.

I've also tried to keep "C:\MinGW\msys\1.0\bin" in PATH and rename
"sh.exe" to "sh.exe.bk" in order to avoid using it.  But I doesn't
work either (I've attached the output generated by "make bootstrap" in
this case).

As you can see, it insist on using sh.exe, and doing "make SHELL=cmd
bootstrap" or "make SHELL=cmd.exe bootstrap" don't work either (It
stops processing just after hitting RET, as described earlier).

Dani Moncayo

Attachment: make2.log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]