help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w3 again,


From: Roger Mason
Subject: Re: w3 again,
Date: Wed, 2 Oct 2002 12:04:40 -0230

Hello,

I have now found the problem.

Firstly, you were correct that running sources vs. byte-code helps to sort
the problem.

Weh I run source code, with debug-on-error set to 't' I get the following
backtrace on invoking m-x w3:

Loading w3 (source)...
Loading cl-macs...done
Loading cus-edit...
Loading easymenu...done
Loading cus-edit...done
Loading w3 (source)...done
Loading url-auth (source)...done
Loading cl-seq...done
Loading w3-hot (source)...done
Cannot determine format of hotlist file:
/home/rmason/.mosaic-hotlist-default
Contacting host: www.cs.indiana.edu:80
Loading url-cache (source)...done
Downloading of `http://www.cs.indiana.edu/elisp/w3/docs.html' complete.
Parsed  80% of 2951...
Parsed 100% of 2951...done
Drawing... done
error in process filter: if: Symbol's value as variable is void:
font-running-xemacs
error in process filter: Symbol's value as variable is void:
font-running-xemacs

On grepping for this variable in the site-lisp directory, I find it is not
defined, so I put

;; Kludge by rm Oct. 2 2002
(defvar font-running-xemacs nil
"True if this is Xemacs.  By default I set it to nil.")

in w3.el, and now everything seems to be OK.

I have not yet tried compiling and running compiled the code.

Thanks to all who assisted.

Roger Mason

On Sat, 28 Sep 2002, Kai [iso-8859-15] Gro├čjohann wrote:

> Roger Mason <rmason@sparky2.esd.mun.ca> writes:
> 
> > I checked the config.log for the url & w3 packages: the configure script
> > found 21.1 in both cases, which is correct.
> 
> Hm.  Could you M-: (load "w3.el") RET, then try again?  Maybe now the
> backtrace is better, or the issue goes away completely.
> 
> kai
> -- 
> ~/.signature is: umop ap!sdn    (Frank Nobis)
> _______________________________________________
> Help-gnu-emacs mailing list
> Help-gnu-emacs@gnu.org
> http://mail.gnu.org/mailman/listinfo/help-gnu-emacs
> 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]