[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs 21.2.1, rmail, and metamail

From: Akop Pogosian
Subject: Emacs 21.2.1, rmail, and metamail
Date: Sat, 5 Oct 2002 01:56:39 +0000 (UTC)
User-agent: tin/1.4.5-20010409 ("One More Nightmare") (UNIX) (SunOS/5.6 (sun4u))

Hello. I'd like to ask this question on the newsgroups to make sure I
am not doing anything wrong before I submit a bug report. In the old
version of emacs (20.x), if you run M-x metamail-interpret-body, the
metamail program would be run to inspect the message body and perform
the appropriate actions according to how the mailcap file setup (e.g.
usually extract and attachment and launch some program to view it).

Starting with emacs 21.x this command stopped working. When I run M-x
metamail-interpret-body, or M-x metamail-buffer, I simply see the
message text scrolling before me and nothing else happens. If I save a
message in a separate file and run metamail on it, it works as
expected, so it is possible that emacs is doing something odd. I
replaced the metamail program with a shell script that saves the file
that's passed to it with arguments somewhere so that emacs doesn't
delete it when metamail returns. I looked at that file and I noticed
that the header "Content-Type: MULTIPART/MIXED;" is missing in it. For
some reason emacs removes it before running metamail. I am getting
this when I run M-x metamail-buffer or M-x metamail-interpret-body.
The absence of this header seems to confuse metamail. I simply see
text scrolling and nothing else happening if I run metamail on that
file from command line. Is this an emacs bug or is there something
that I am doing wrong?

Akop Pogosian

This space has been accidentally left blank.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]