[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

resize timeout message with gdb

From: Theodric Young
Subject: resize timeout message with gdb
Date: 17 Oct 2002 17:48:41 GMT

Hi folks,

I use the gdb debugger from within emacs for debugging programs that I
write in C for a Linux machine.  Whenever I try to run a program from
within gdb, I get the following very annoying message:

 (gdb) run
 Starting program: /usr/local/dev/bin/myprogram
 resize: Time out occurred

It's annoying because it sits and waits for about 15 seconds between
printing the control characters on the second line and the timeout
message on the third line.  After getting this message, gdb works
great from within emacs and I can step through my program with no

I assume that it's trying to send some sort of resize command to my
window that my window is ignoring.  But I don't know what command or
function it's calling to do this, and I don't know why it's not
working, or even why it's trying to do this.

I'm not actually using X here, I'm running emacs in text mode from an
ssh shell (so no mouse control, etc.).  I do this same exact thing on
several different systems, including a Solaris machine and a couple
different Linux systems, and I never see this problem on any other

I thought perhaps it was a configuration issue with the emacs/gdb
installation that came with our Linux distribution, but I've
downloaded and compiled the latest versions of emacs and gdb and I
still see the same problem.  I've also tried changing a lot of
different environment variables (like TERM, HOSTNAME, etc.) to see if
those were confusing emacs, but those have no effect.

When I change the size of my terminal window, emacs changes the
size of it's buffers exactly as one would expect, so there *is*
communication between my shell window and the emacs process which
*does* work correctly.  The only time I see a problem is when trying
to run a program from within gdb.

If I run gdb from the command line, I don't see this message.  The
message only occurs when invoking gdb from within emacs.

emacs version:
  GNU Emacs 21.2.1 (i686-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
  Red Hat Linux release 7.0 (Guinness)
  Kernel 2.2.17-8 on an i686

I assume that it's a configuration option that's just set wrong
somewhere, but I really don't know where to look.  Any help here would
be greatly appreciated.

Thanks in advance,

Theodric Young
WMBR 88.1 FM at MIT

reply via email to

[Prev in Thread] Current Thread [Next in Thread]