[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: a Messages buffer puzzle

From: Tim Cross
Subject: Re: a Messages buffer puzzle
Date: 11 Nov 2002 16:59:49 +1100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Harry Putnam <> writes:

> I'm noticing a local behavior that is not default but can't tell what
> setting of mine is causing it.
> With emacs-21.2: 
> Normally when one presses M-x version, the version info appears in
> echo area and is written to *Messages* buffer.  On my local setup when
> I press M-x version <RET> I see the info in echo area but only an
> uppercase `G' gets printed to *Messages*.
> If I start a vanilla (-q -no-site-file) emacs, the behavior returns to
> normal.
> What might be causing this?

I have noticed very similar behavior - on my system here at work, M-x
version works as you would expect - with the info printed to the
**Messages) buffer as well. However, I have noticed quite often in
Emacs 21 you will get a single upper-case letter in the *Messages*
buffer. Sometimes I have noticed this when trying to track down an
error - sometimes there is an error message there with an upper-case
letter on a line by itself either before, after or in the middle of
the message and sometimes its
just an upper case letter. 

I've not been able to rack down the cause (but have not tried hard
either). I have noticed the frequency of this seems to be decreasing
as I add updated versions of some of the packages I run - maybe its
some strange interaction resulting from the changes between 20 and 21?

Although I have no explination or solution, there is some comfort in
knowing your not alone!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]