[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

? OSX compile from CVS (and some setup questions)

From: Heiko Hellweg
Subject: ? OSX compile from CVS (and some setup questions)
Date: 11 Nov 2002 13:19:14 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

I tried (and failed) to build my own Emacs on Mac OSX.2 
directly from CVS (checked out today: 11th. of Nov. 2002)
as described on

  cvs -z3 co emacs
  cd emacs
  ./configure --with-carbon --without-x
  make bootstrap

wich came up with the following error:

Compiling /Users/hh/tmp/emacs/emacs/lisp/progmodes/cc-mode.el
>>Error occurred processing 
>>/Users/hh/tmp/emacs/emacs/lisp/progmodes/cc-mode.el: Symbol's function 
>>definition is void ((char-table-p))
make[1]: *** [compile] Error 1
make: *** [bootstrap] Error 2

Is this a known bug in the current CVS? Or is there something obvious 
i missed? I checked the recent emacs-devel archive 
but most (end users) comilation problems there seemed to center
on trying just 'make' without the bootstrap ...

Failing that, i got myself a precompiled binary version
(GNU Emacs (powerpc-apple-darwin6.1)) from (which i'm using
right now in conjunction with gnus...) and - well - i've still
got some questions:

first of all: when i start emacs from the commandline (Aqua or
tty via '-nw') with a filename as parameter, as in
        /Applications/ -nw textfile.txt
it starts up showing the general info (the usual 20 or such lines: 
"Welcome to GNU Emacs ...") and only shows the contents of textfile.txt
after i pressed some key. 
That is quite irritating. Is there a way to turn this of?

second: running that emacs on the tty, it seems not to honor
my colorized vt100 terminfo entry:

hh@ifruit:emacs/ %infocmp vt100
#       Reconstructed via infocmp from file: /Users/hh/.terminfo/v/vt100
        am, xenl, 
        colors#8, cols#80, it#8, lines#24, pairs#64, vt#3, 
        bel=^G, blink=\E[5m$<2/>, bold=\E[1m$<2/>, 
        clear=\E[;H\E[2J, cr=^M, csr=\E[%i%p1%d;%p2%dr, cub1=^H, 
        cud1=^J, cuf1=\E[C$<2/>, cup=\E[%i%p1%d;%p2%dH$<5/>, 
        cuu1=\E[A$<2/>, ed=\E[J$<50/>, el=\E[K$<3/>, home=\E[H, 
        ht=^I, ind=\ED$<2*/>, kbs=^H, kcub1=\EOD, kcud1=\EOB, 
        kcuf1=\EOC, kcuu1=\EOA, kf1=\EOP, kf2=\EOQ, kf3=\EOR, 
        kf4=\EOS, nel=\r\ED$<2*/>, op=\E[m, rc=\E8, rev=\E[7m$<2/>, 
        rf=/usr/share/tabset/vt100, ri=\EM$<2*/>, 
        rmkx=\E[?1l\E>, rmso=\E[m$<2/>, rmul=\E[m$<2/>, 
        sc=\E7, setab=\E[4%p1%dm, setaf=\E[3%p1%dm, 
        setb=\E[4%p1%dm, setf=\E[3%p1%dm, sgr0=\E[m$<2/>, 
        smkx=\E[?1h\E=, smso=\E[7m$<2/>, smul=\E[4m$<2/>, 

The apple supplied emacs (GNU Emacs 21.1.1 (powerpc-apple-darwin6.0)),
and a fink installation of (GNU Emacs 21.2.1 (powerpc-apple-darwin, X toolkit))
[see] used color for
font-lock-mode , while the Aqua build reverts to bold/underline
on the tty... 

I also tried the ~/.termcap suggestion from the (cvs source)/mac/INSTALL
file without success.

On the other hand, that Aqua buld seems to be the only
one that accepts 8bit ISO8859-1 umlauts on the tty. the apple 
supplied version always cut of the high bit (e.g. 'ä'=0xe4 becomes
'd'=0x64)... anyone got an idea, why they won't accept, that
is 8 bit clean? 'stty -a' says, among other things:

cflags: cread cs8 -parenb -parodd hupcl -clocal -cstopb -crtscts -mdmbuf

... oh well ... seems like i'm stuck with either having color or umlauts 
on the tty... (yes: for some reason, i prefer tty emacs).

I hope, all that rambling makes sense.
bye - Heiko

reply via email to

[Prev in Thread] Current Thread [Next in Thread]