[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Q: Configuring Tramp on WinNT

From: Jack Saba
Subject: Q: Configuring Tramp on WinNT
Date: Mon, 10 Nov 2003 16:30:55 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

I am trying to configure tramp to be able to connect from the Win NT machine on my desk to our Unix machines, but have not been able to get it to work. Any suggestions would be appreciated. Much of what I have working is because of the documents put together by T Roche, but his web page does not seem to be available currently.

plink is set up. I can use plink from a shell window to connect, and I can connect in an Emacs shell buffer using plink-ssh after typing in a password. However, although it does work, the following shows up in the Emacs plink connection buffer:

"The server's host key is not cached in the registry. You
have no guarantee that the server is the computer you
think it is.
The server's key fingerprint is:
If you trust this host, enter "y" to add the key to
PuTTY's cache and carry on connecting."

Unfortunately, plink continues on without giving me a chance to answer y or n. Since I am connecting with putty outside of Emacs, our sysadmin says the keys are set up correctly.

When I try to use tramp, it asks for a password but then seems to go into a loop. I am not running through cygwin. The tramp debug buffer shows the following --

 # Opening connection at MYMACHINE using nil...
 # Waiting for prompts from remote shell
 # Waiting 60s for prompt from remote shell
 # Looking for regexp "^.*\([pP]assword\|passphrase.*\):^@ *"
   from remote shell
 # Looking for regexp ".*ogin: *" from remote shell
 # Looking for regexp "^[^#$%
 ]*[#$%] *" from remote shell
 # Looking for regexp "^[^#$%
 ]*[#$%] *\(\[[0-9;]*[a-zA-Z] *\)*" from remote shell
 # Looking for regexp "^.*\(Connection \(?:\(?:clo\|refu\)sed\)\|Host key
 verification failed\.\|Login \(?:[Ii]ncorrect\)\|Name or service not
 known\|\(?:Permission denied\|Sorry, try again\)\.\).*\|^.*\(Received signal
 [0-9]+\).*" from remote shell

 and repeat forever, or at least until I hit ^G

 In the .emacs file, I have:

 ;;;         plink setup for tramp
 ;;; SSH to host.
 (setq plink-program "plink")
 (defun plink-ssh (host)
    "Open a ssh (secure shell) connection. See `plink'."
    (interactive "sOpen ssh connection (user@host): ")
    (plink host "-ssh"))

 ;; Telnet to host.
 (defun plink (host &optional ssh-string)
    "Open a telnet connection to host named HOST (a string).
 Communication with HOST is recorded in a buffer `*plink-HOST*'.
 Normally input is edited in Emacs and sent a line at a time."
    (interactive "sOpen telnet connection (user@host): ")
    (require 'shell)
    (let ((name (concat "plink-" host))
          (password (comint-read-noecho "password: " t))
          (opt-string (if (eq ssh-string nil) "" ssh-string)))
       (make-comint name plink-program nil opt-string host "-pw" password))
      (set-process-filter (get-process name) 'telnet-initial-filter)
      (accept-process-output  (get-buffer-process (current-buffer)))
      (send-string (get-buffer-process (current-buffer))
                   "stty echo\n")
      (setq telnet-count -16)))
 (require 'tramp)
 (setq tramp-verbose 10)
 (setq tramp-debug-buffer t)

I tried including

 (add-to-list 'tramp-methods...

in the .emacs file, but was not able to come up with a combination of parameters that worked.

Jack Saba
jack . saba @ gsfc . nasa . gov

reply via email to

[Prev in Thread] Current Thread [Next in Thread]