[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Q: Configuring Tramp on WinNT

From: Peter Lee
Subject: Re: Q: Configuring Tramp on WinNT
Date: Tue, 11 Nov 2003 16:11:17 GMT
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (windows-nt)

>>>> Jack Saba writes:

    Jack> in the .emacs file, but was not able to come up with a
    Jack> combination of parameters that worked.

I have the following in my .emacs :

(require 'tramp)
(add-to-list 'tramp-methods 
              (tramp-connection-function  tramp-open-connection-rsh)
              (tramp-login-program        "plink")
              (tramp-copy-program         nil)
              (tramp-remote-sh            "/bin/sh")
              (tramp-login-args           ("-2" "-ssh"))
              (tramp-copy-args            nil)
              (tramp-copy-keep-date-arg   nil)
              (tramp-password-end-of-line "xy")))

(setq tramp-default-method "plink2")

This allows me to 'C-x d /user@host:/home/user RET' and get a
directory listing.  I can browse and copy files (text only) with no
problem.  However, if I try to open a remote shell (using plink) from
eshell I run into the same problems as you.

Basically I've just been using a seperate cmd (or cygwin) window for
that purpose.

Just some more info that may help... if you solve the eshell problem
please post your solution.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]