[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-gsl] compile with static GSL(1.4) libraries: G++(3.3) OS X(10.3.5)

From: John Gehman
Subject: [Help-gsl] compile with static GSL(1.4) libraries: G++(3.3) OS X(10.3.5)
Date: Tue, 7 Dec 2004 14:37:30 +1100

Hello All,

I'm having some problems sorting out compiling problems: I tried to provide my boss with an executable (which uses GSL) that I compiled on my OS X (10.3.5) iBook (via g++ -o myprogram -lgsl -lgslcblas mycode.c, and works fine on my machine); she also has a recent iBook, although I'm not certain it's the same OS X version/update. The error she gets trying to run it says something to the effect of "can't find libgsl.o.dylib ..." I presume this means that I need to include static versions of the gsl libraries when compiling, and I can't work out how.

I've tried:
--including the -static flag {and get "/var/tmp//ccetJK2B.s:1328:FATAL:incompatible feature used: directive .non_lazy_symbol_pointer (must specify "-dynamic" to be used)" } --recompiling my gsl-1.4 with "./configure --disable-shared" , but the executables are exactly the same size following compiling. The -static flag does the same thing as before. --including the explicit libgsl.a and libgslcblas.a paths as just more source code when compiling, and I get ld: Undefined symbols: then a list of every gsl function and construct I use. --including the explicit and paths as well and get ld: /usr/local/lib/ bad magic number (not a Mach-O file) (and same for libgslcblas).
--including -static-libgcc (no effect)

Obviously I'm flailing, trying an incoherent smattering of all the little snippets I can find that appear to address the issue. Has anybody compiled code on their machine and ran it elsewhere (where gsl was not loaded)? How?

Thank You!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]