[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] solaris / gcc linker problems during intall

From: Brian Gough
Subject: Re: [Help-gsl] solaris / gcc linker problems during intall
Date: Tue, 21 Dec 2004 16:36:30 +0000

matt hall writes:
 > i'm trying to install gsl on my solaris box (sunblade 1500/solaris 2.8)
 > using gcc 3.4.1 and i am getting linker errors (see below). I have tried
 > ./configure --disable-shared and received the same error, and have also
 > tried setenv LD_LIBRARY_PATH /usr/local/lib:$LD_LIBRARY_PATH (i am using
 > csh) which produced: LD_LIBRARY_PATH: Undefined variable.

We use libtool 1.4.3 -- if you look in the libtool manual for that
version it will tell you if your combination of compiler/linker and OS
are supported.  If so (and I believe they are) please send the
complete ./configure --disable-shared output to address@hidden along
the error messages from the build (make sure to use a completely clean
tree, e.g. by unpacking the tar file into a new directory).

Brian Gough

Network Theory Ltd,
Commercial support for GSL ---

p.s. setting the LD_LIBRARY_PATH will not have any effect at link
time, only at runtime:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]