[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] GSL 1.9 Cygwin installation

From: Jordi Gutierrez Hermoso
Subject: Re: [Help-gsl] GSL 1.9 Cygwin installation
Date: Fri, 23 Mar 2007 10:13:18 -0600

On 23/03/07, address@hidden <address@hidden> wrote:

The main problem here of course is that I'm using WinXP and Cygwin
for exactly that reason that my general understanding of Linux is

In my experience, getting free software working under Windows feels
quite kludgy. The GSL feels more at home in a GNU/Linux
environment. On this note,

for installing Debian, or

for installing Ubuntu. Under apt-based GNU/Linux distributions like
these, there is no need to compile the GSL. Once you have Debian or
Ubuntu set up and the proper online repositories configured, you can
run as root (as administrator, usually with the sudo or su command)
the command "aptitude install libgsl0 libgsl0-dev" from a command-line
(a shell, a console, a terminal, for now all synonyms until you figure
out the subtle differences). This will automatically download,
install, and configure the GSL without further action from you.

Ubuntu should make it easy to get apt configured so that you can run
the aptitude command, Debian has a reputation for making it a little
harder, but it should not be signficantly more complicated. In Ubuntu
the GSL is probably in the Universe section, so you might need to get
it enabled when you configure apt, in Debian it's in the main section.

I'm trying to install GSL 1.9 with Windows XP Cygwin, but I'm
getting errors I don't understand. So it is very likely that I'm
just doing something wrong, but I can't figure it out.

Possibly... In case you still decide against attempting to install
Debian or Ubuntu, let me try to help you with your Windows problems.

Running configure seems to be going OK, but when I run make, I get errors:

make.exe[1]: *** [all-recursive] Error 1
make.exe: *** [all] Error 2

This isn't enough information to diagnose the problem. Can you post
the last ten lines or so before Make dies?

I get these by running make after both "./configure" and "./configure
--disable-shared". I have also tried to ignore these and run "make install"
anyway, but it doesn't seem to work that way. I have attached to this mail
the output logs of each command in the sequence

make check
make install

to give maximum information.

I looked at these logs, but they contain very little information that
could help to diagnose the problem. You are correct that the configure
script seems to run to completion without problems, although I see a
lot of errors about header files it can't find. Under an apt-based
GNU/Linux distribution, these missing header files are under the
libc6-dev package (the GNU C library development package), and I would
expect the standard Cygwin distribution to include it. Check that all
gcc development files exist, e.g. inttypes.h; and also try a gcc
sanity check by compiling a Hello World.

Let me know how it goes.

- Jordi G. H.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]