help-gsl
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] definition of gsl_matrix_row()?


From: Frank Reininghaus
Subject: Re: [Help-gsl] definition of gsl_matrix_row()?
Date: Sat, 22 Mar 2008 11:44:07 +0100
User-agent: KMail/1.9.6 (enterprise 0.20070907.709405)

Hi Allin,

the definition of gsl_matrix_row () is not as easy to find as the prototype 
because the name of the function does not appear literally in the definition.

Look at the matrix/ subdirectory of the GSL source distribution. The 
file "rowcol.c" defines all gsl_matrix_*_row () and gsl_matrix_*_column () 
functions for variuous types "*" (for the default type "double", "*" is left 
out in the function names).

To avoid code duplication, the code that is independent of the type "*" is 
contained in "rowcol_source.c". For each type, the file "rowcol.c" defines 
something like "BASE_GSL_COMPLEX_LONG" and includes the header 
file "templates_on.h" which defines some stuff that makes "rowcol_source.c" 
work correctly for the respective type.

Frank

On Saturday 22 March 2008 01:49:51 Allin Cottrell wrote:
> Hello,
>
> I'm interested to know how gsl_matrix_row() is implemented.  By
> grepping the sources, I'm able to find a prototype for this
> function and a lot of uses, but not a definition, yet clearly it
> must be defined somewhere!  Help, please!






reply via email to

[Prev in Thread] Current Thread [Next in Thread]