[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-gsl] Re: gsl not getting along with gdb

From: psood1
Subject: [Help-gsl] Re: gsl not getting along with gdb
Date: Thu, 6 Nov 2008 10:08:18 -0500


No -- the files don't exist. Also, I've tried gsl-1.11 (and 1.10 and 1.9...
:( ).

Do you think I have an outdated version of libtool?


On Thu, Nov 6, 2008 at 9:57 AM, Rodney Sparapani <address@hidden> wrote:

> address@hidden wrote:
>> When I try to use gdb to step through GSL functions, I get a series of
>> warnings of the form:
>> warning: Could not find object file
>> "/Users/mydir/gsl-1.10/.libs/libgsl.lax/libgslwavelet.a/dwt.o" - no debug
>> information available for "dwt.c".
>> My code compiles correctly.
>> I'm running version 1.10 of GSL on a Mac Leopard OS. I've tried installing
>> from both source and using package managers (both fink and darwinports).
>> All
>> installations take place correctly, without any errors. The only
>> installation I have now is from source, having uninstalled other versions.
>> However, I get the warnings mentioned above when I use gdb.
>> Has anyone had this problem before? Does anyone know how to fix it? My
>> next
>> step is throwing my computer out the window.
>> Thanks.
> Well, I've seen similar problems caused by libtool bugs, but not with gdb
> per se.  Do these files actually exist?  If it is a libtool bug,
> then there is always hope that it has been fixed.  Did you try GSL 1.11?
> --
> Rodney Sparapani      Center for Patient Care & Outcomes Research (PCOR)
> Sr. Biostatistician    
> 4 wheels good, 2 wheels better!  Medical College of Wisconsin (MCW)
> WWLD?:  What Would Lombardi Do?  Milwaukee, WI, USA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]