[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-gsl] undefined reference problem

From: Alexander Kubisch
Subject: [Help-gsl] undefined reference problem
Date: Fri, 16 Jan 2009 14:51:21 +0100
User-agent: Mozilla-Thunderbird (X11/20090103)


I just tried to compile my C++-program in eclipse with the following makefile:

env_grad.out : main_program.o
   g++ -o env_grad.out main_program.o
main_program.o : main_program.c++ classes.h procedures.h
   g++ -c -lgsl -lgslcblas -lm main_program.c++
clean :
   rm -f *.o

The compilation aborts and for every line of program code, in which I use gsl-functions, the "undefined reference to" - error occurs. In the Includes the gsl-folder is listed and I also tried other compiler-commands, like -L/usr/include/gsl and others. Always the same problem appeared. Do you have any idea, what could be the reason for that? BTW, I'm not a programmer, I'm a biologist, so I'm sorry, if this might be a nooby question ;-)

Many thanks,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]