[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-gsl] Help with linking / loading libraries on Ubuntu 10.10

From: Randall Morgan
Subject: [Help-gsl] Help with linking / loading libraries on Ubuntu 10.10
Date: Fri, 24 Feb 2012 07:12:15 -0800


I am new to gsl and fairly new to Ubuntu and Linux in general. I am trying
to wrap the library for use in Gambas a C component. My component compiles
without error if I comment out my function that uses the
gsl_poly_complex_eval() function call. If I leave this call in I get an
error telling me the 1. I am attempting to assign an int to a gsl_complex,
and 2. The gsl_poly_complex_eval function is undefined.

I tried writing a simple C program to use this function (a few other gsl
functions) and find that I can use other gsl function fine but cannot use
the gsl_poly_complex_eval. Again, in the C program I get a
gsl_poly_complex_eval() undefined symbol error.

I then tried compiling the library from gsl-1.9 code and adding the
usr/local/lib directory to LD_LIBRARY_PATH. This did not fix the issue.

Can anyone tell me how to diagnose this issue? What should I check/try
next?  Is gsl-1.9 the latest version?

Thank you for you help in this matter.


If you ask me if it can be done. The answer is YES, it can always be done.
The correct questions however are... What will it cost, and how long will
it take?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]