[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error in gexp.scm. Unrecognized keyword.

From: ng0
Subject: Re: Error in gexp.scm. Unrecognized keyword.
Date: Sat, 24 Sep 2016 21:25:31 +0000


Dmitry Nikolaev <address@hidden> writes:

> Hi.
> I wanted to update my GuixSD installation, but everytime I run "guix system
> reconfigure ..." I'm getting
> guix/gexp.scm:314:0: In procedure computed-file:
> guix/gexp.scm:314:0: In procedure #<procedure computed-file (name gexp
> #:key options)>: Unrecognized keyword
> I've tried guix pull and guix refresh, nothing helped.
> What is wrong with my guix installation and gexp.scm? I haven't seen
> anybody complaining about it in this mailing list. What do I have to do to
> update my GuixSD installation?
> Dmitry Nikolaev

What is the exact command you are running?

The reconfigure needs to be passed the system config file, usually named
config.scm (as suggested by the documentation).

So when I update my systems I do:

guix system build /etc/config.scm; sudo guix system reconfigure /etc/config.scm


reply via email to

[Prev in Thread] Current Thread [Next in Thread]