[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error in gexp.scm. Unrecognized keyword.

From: Leo Famulari
Subject: Re: Error in gexp.scm. Unrecognized keyword.
Date: Sun, 25 Sep 2016 12:56:41 -0400
User-agent: Mutt/1.7.0 (2016-08-17)

On Sat, Sep 24, 2016 at 11:35:36PM +0300, Dmitry Nikolaev wrote:
> Hi.
> I wanted to update my GuixSD installation, but everytime I run "guix system
> reconfigure ..." I'm getting
> guix/gexp.scm:314:0: In procedure computed-file:
> guix/gexp.scm:314:0: In procedure #<procedure computed-file (name gexp
> #:key options)>: Unrecognized keyword
> I've tried guix pull and guix refresh, nothing helped.

Slightly off-topic, but you probably don't need to use `guix refresh`
here. `guix refresh` is used to automatically update some package
definitions in a Git checkout of Guix, while testing new upstream
releases before sending the updates to guix-devel. It's not part of a
typical GuixSD system update process.

> What is wrong with my guix installation and gexp.scm? I haven't seen
> anybody complaining about it in this mailing list. What do I have to do to
> update my GuixSD installation?

Most likely there is some problem with your OS configuration (typically
'/etc/config.scm'). Can you share it if there is nothing sensitive or
private in it?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]