[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: %desktop-services #:select service alsa-service-type - unbound varia

From: znavko
Subject: Re: %desktop-services #:select service alsa-service-type - unbound variable
Date: Thu, 20 Sep 2018 17:07:08 +0000

Thank you for your response, Pierre Neidhardt!
I tried NetworkManager on GuixSD and have no troubles with it. But I dislike NM 
cause it stores wifi password as it is, but wpa_supplicant saves hash only. Of 
course, I want delete NetworkManager cause I want to control network by myself 
without such a monster. Further I will configure dnsmasq and I know NM pretty 
cool linked with it, but no.

As it is now, I tried to move config to /etc/wpa_supplicant/wpa_supplicant.conf 
and reboot. So the service wpa-supplicant was running

# herd status wpa-supplicant
Status of wpa-supplicant:
  It is started.
  Running value is 324.
  It is enabled.
  Provides (wpa-supplicant).
  Requires (user-processes dbus-system loopback).
  Conflicts with ().
  Will be respawned.

But I could not connect to network running `dhclient -v wlp2s0` so I think I do 
not know how get wpa-supplicant service to use my config by default.

Your piece of code grews like this:

# cat /etc/config.scm
  (services (cons* (xfce-desktop-service)
                    (remove (lambda (service)
                     (eq? (service-kind service) network-manager-service-type))

As I can understand guix will compile entire system with such config.scm from 
sources, cause such configuration is not presented in GuixSD servers, am I 

This construction is hard understandable for me. did not help this time. I 
want also to delete polkitd, avahi, cups, but I have troubles from start 
learning Scheme:
I tried 2 Scheme compilers: MIT-Scheme and Chicken, but their behavior is quite 
different even with 'print' function. MIT-Scheme gives errors on `(print x)` 
and `print x`.  But (lambda (service) ...) is very hard.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
четверг, сентябрь 20, 2018 6:50 вечера, Pierre Neidhardt <address@hidden> пишет:

> Hello,
> I'm not sure I understood all your issues, so I'll try out some suggestions:
> -   The ALSA-related options are defined in the `(gnu services sound)` Guile 
> module.
>     Import the module to your config file and it should fix your issue.
>     This is documented in the "(guix) Sound Services" section of the manual.
> -   NetworkManager: have you tried it? Does it work? You might not have the 
> same
>     issues with it on Guix than on Funtoo. I suggest you give it a try first.
>     Like you, I had a poor opinion of NetworkManager before I tried it on 
> GuixSD.
> -   If you really want to turn off NetworkManager, I suggest you remove the
>     service from your config. For instance (untested):
>     (services
>     (remove (lambda (service)
>     (eq? (service-kind service) network-manager-service-type))
>     %desktop-services))
>     With NetworkManager disabled, wpa_supplicant and dhclient should also be
>     disabled. Check the running processes.
>     -   If you want to run the wpa_supplicant Guix service, I don't know you 
> can
>         specify a custom config. From the documentation and the source code in
>         (gnu services networking), it does not seem to be customizable but I 
> suppose
>         that it reads /etc/wpa_supplicant anyways.
>     -   Otherwise, disable wpa_supplicant / dhclient services just like you 
> did with
>         NetworkManager if necessary. Then you are free to run them manually 
> with your
>         custom script.
>         Hope that helps!
>         --
>         Pierre Neidhardt

reply via email to

[Prev in Thread] Current Thread [Next in Thread]