[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Frequent git repository corruptions

From: Pierre Neidhardt
Subject: Frequent git repository corruptions
Date: Wed, 26 Sep 2018 12:03:42 +0200
User-agent: mu4e 1.0; emacs 26.1

Hi Guix!

This might be unrelated to Guix but since I'm in the dark here, I
figured I'd rather ask, maybe someone ran into a similar issue.

For the past 2-4 weeks I've had at least 4 Git repositories that got
corrupted for no apparent reason.  Even a checkout that I had never

When it happens, errors show up on most git commands, usually `git diff`
but sometimes also `git status`:

--8<---------------cut here---------------start------------->8---
> git diff
error: object file .git/objects/e0/1bd6c3c77309b13dab22f9e0de33576ede944f is 
fatal: unable to read e01bd6c3c77309b13dab22f9e0de33576ede944f
--8<---------------cut here---------------end--------------->8---

A quick Internet search led me to realize there is little to do to
recover the corrupted repository beside cloning it again.  I haven't
lost anything so far, knock on wood.

My first thought was a hard drive issue.  I have a NVMe SAMSUNG
I ran some smartmontools test, everything looks fine.

But now that I think about it, I did not notice any other issue than
within the .git folder, so maybe it's a... Git issue?

Would it be possible that the Guix package of Git be the culprit?
I run git 2.19.0 and a repo got corrupted just this morning.

I use emacs-magit all the time.  Not sure it's related considering that
a repository I never edited also got corrupted.


Pierre Neidhardt

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]