[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't log in: blank login screen after reconfigure

From: Björn Höfling
Subject: Re: Can't log in: blank login screen after reconfigure
Date: Sun, 21 Oct 2018 18:01:13 +0200

On Sat, 20 Oct 2018 12:21:51 -0700
Chris Marusich <address@hidden> wrote:

> Hi,
> I recently ran "guix pull" and then "guix system reconfigure" on a
> GuixSD installation in a VirtualBox VM.  Since doing that, I can't log
> in.  While booting, everything proceeds as usual, with normal output,
> until the SLiM login screen is supposed to appear.  But instead of the
> SLiM login screen, I get a blank screen with a small white cursor in
> the upper left, and I can't log in.
> Has anyone seen anything like this in the past?  Here are some
> observations I've made about the situation:
> * GuixSD shuts down normally if I issue the "shutdown signal" from
>   VirtualBox.  This indicates the OS is actually still running.
> * I waited over 8 hours, and the login screen did not appear.
> * I tried blind-typing my user name and password, but the blank screen
>   remained.
> * When I boot from the previous system generation, there is no
> problem.
> * When I replace SLiM with SDDM in my OS configuration and
> reconfigure, the same problem occurs.
> * However, one time only, while trying to boot using SDDM instead of
>   SLiM, I got to the SDDM login screen.  But when I typed in my
> username and password and hit enter, I received the same blank screen
> as before and ultimately could not log in.  Every other time I've
> booted the VM, I didn't even get to the SDDM login screen, so I don't
> know why I was able to reach the login screen that one time.
> * I tried pressing control+alt+F2 etc. to switch to different virtual
>   tty, but it didn't work.  The blank screen remained.
> * I examined various system logs, but I could not find anything that
>   jumped out at me as causing the problem.  It's entirely possible I
>   missed something important, though; I just checked a few places.
> There is more that I could try - for example, I could try starting an
> ssh server in my VM and logging in that way.  I could also try
> drilling deeper into the X server logs, since that seems like the
> obvious next step, since the problem occurs for both SDDM and SLiM.
> I could also try reinstalling GuixSD in a new VM.  But I haven't
> tried any of this yet due to lack of time.
> If anyone has any advice or has seen this before, please let me know.
> Thank you!

Hi Chris,

to be honest, I have no idea what SlimD and SDDM is.

I'm using a configuration containing a %desktop-services with
xfce-desktop-service added.

I just guix pulled, guix system reconfigured and be on:


and it works for me, I see a login, can login, XFCE is working

If I can try out anything specific for you, let me know.


Attachment: pgpRG4ng5ZmgN.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]