[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

btrfs and subvolumes for root, take 2

From: Fredrik Salomonsson
Subject: btrfs and subvolumes for root, take 2
Date: Sun, 25 Nov 2018 11:14:17 -0800


A little more than a year ago I tried installing GuixSD to a btrfs
subvolume and boot from that. Didn't work that great as I got stuck when
trying to boot. As it couldn't find the linux kernel.

I decided to try this again. Got a little bit further this time around.

To get past the boot problem I needed to manually modify grub.cfg, for
it find the subvolumes where the gnu/store is located.

Problem is now that it fails when populating /etc. Seems that it tries
to symlink /etc/ssl twice and errors out the second time as the file
already exist. I attached a picture I took of the error message.

Also attached my config.scm and my modified grub.cfg

These are the steps I did to install GuixSD

guix archive --authorize < 
guix pull --commit=d9f8e84 --substitute-urls="";
guix system init /mnt/etc/config.scm /mnt 

I haven't tried the latest commit as it doesn't seem to have that many
substitutes built for it. And last time I ran guix system init with poor
substitute coverage it took about 6h on my laptop.


PS. I tried responding to the old thread about this but got rejected due
to the email being too long. I probably include the whole thread in my
email. Still trying to figure out emacs+notmuch. Hopefully this is better.

Attachment: IMG_20181124_184634.jpg
Description: Guile backtrace

Attachment: config.scm
Description: GuixSD Configuration

Attachment: grub.cfg
Description: Grub config


reply via email to

[Prev in Thread] Current Thread [Next in Thread]