[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix pull fail to update

From: swedebugia
Subject: Re: guix pull fail to update
Date: Wed, 05 Dec 2018 00:30:48 -0800

On 2018-12-05 07:22, Guy fleury wrote:
> I installed the package and set the environment variables describes in
> the manuel but the error still the same!
> Le 5 déc. 2018 07:23, "Leo Famulari" <address@hidden> a écrit :
>> On Wed, Dec 05, 2018 at 07:20:36AM +0200, Guy fleury wrote:
>>> Hi guix,
>>> Yesterday i installed guixsd with the bare-bornes config example.
>>> The system works.But when i run guix pull to update my
>> system,after a
>>> moment i get this error:
>>> guix pull: error: Git error:SSL error: received early EOF

I advise you to wait a couple of days for 0.16 and init from that which
hopefully will work better.

I any case this might work:

Could you provide:
1 complete output of the command and invokation?
2 try pulling an earlier commit (a few days back) and see if that works?
2.5 maybe try specifying the pull url with https substituted with http?

try this:
guix pull --url=

3 if you did not pull before guix system init you are on 0.15. You are
then running legacy code but guix pull should still work. guile-ssh was
added to the dependencies not long ago so this could be related.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]