[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Stuck upgrading from Guix v0.12

From: Paul Garlick
Subject: Stuck upgrading from Guix v0.12
Date: Mon, 17 Dec 2018 12:29:49 +0000

Hi Guix,

A lesson learnt from a previous update process [1] was; do not leave it too long between 'guix pull' updates.  

However, I have one system running Ubuntu 16.04 and Guix v0.12 that I am trying to update.  As root:

$guix package --list-installed
glibc-utf8-locales 2.25 out /gnu/store/g4g0zhcp5j9pyjmcv02ks4x2b48k252x-glibc-utf8-locales-2.25
guix 0.12.0-9.25a4 out /gnu/store/nqy9m6hhnkkfwr5wyq5bac96v9s9hc9i-guix-0.12.0-9.25a4
gnutls 3.5.9 out /gnu/store/56dbd2gw33g3wdxmq78lr39lamg8gxnq-gnutls-3.5.9
nss-certs 3.30.2 out /gnu/store/3ql0vilc0zv6ra42ghi04787vrg6bb71-nss-certs-3.30.2

When I do 'guix pull' I get an error.  The backtrace suggests reporting a bug:

In unknown file:
   ?: 19 [primitive-load-path "guix/store" ...]
In ./guix/store.scm:
  20: 18 [#<procedure 167b020 ()>]
In ice-9/boot-9.scm:
2987: 17 [define-module* (guix store) #:filename ...]
2962: 16 [resolve-imports (((guix utils)) ((guix config)) ((guix memoization)) ...)]
2900: 15 [resolve-interface (guix utils) #:select ...]
2825: 14 [#<procedure 16ffb40 at ice-9/boot-9.scm:2813:4 (name #:optional autoload version #:key ensure)> # ...]
3101: 13 [try-module-autoload (guix utils) #f]
2412: 12 [save-module-excursion #<procedure 18d53c0 at ice-9/boot-9.scm:3102:17 ()>]
3121: 11 [#<procedure 18d53c0 at ice-9/boot-9.scm:3102:17 ()>]
In unknown file:
   ?: 10 [primitive-load-path "guix/utils" ...]
In ./guix/utils.scm:
  26: 9 [#<procedure 17760a0 ()>]
In ice-9/boot-9.scm:
2987: 8 [define-module* (guix utils) #:filename ...]
2962: 7 [resolve-imports (((guix config)) ((srfi srfi-1)) ((srfi srfi-9)) ...)]
2900: 6 [resolve-interface (guix config) #:select ...]
2825: 5 [#<procedure 16ffb40 at ice-9/boot-9.scm:2813:4 (name #:optional autoload version #:key ensure)> # ...]
3101: 4 [try-module-autoload (guix config) #f]
2412: 3 [save-module-excursion #<procedure 18f3090 at ice-9/boot-9.scm:3102:17 ()>]
3121: 2 [#<procedure 18f3090 at ice-9/boot-9.scm:3102:17 ()>]
In unknown file:
   ?: 1 [primitive-load-path "guix/config" ...]
In ./guix/config.scm:
   1: 0 [#<procedure 1790d40 ()>]

./guix/config.scm:1:437: In procedure #<procedure 1790d40 ()>:
./guix/config.scm:1:437: In procedure module-lookup: Unbound variable: and=>
guix pull: error: You found a bug: the program '/gnu/store/d9dc5jdlhbp4zdx1m9ffr3fmhyg60zy8-compute-guix-derivation'
failed to compute the derivation for Guix (version: "20181217.11"; system: "x86_64-linux";
host version: "20170504.14"; pull-version: 0).
Please report it by email to <address@hidden>.

However, I remember that the package guile-git was not a dependency at the time of v0.12 but it is now.  So, rather than reporting the bug I have tried to install guile-git:

$ guix package -i guile-git
Starting download of /gnu/store/c3npgqn9ag2ypi9bda1g779wwwlcqqrf-libgit2-0.25.1.tar.gz
following redirection to `'...
 v0.25.1                                     1.3MiB/s 00:03 | 4.1MiB transferred
output path `/gnu/store/c3npgqn9ag2ypi9bda1g779wwwlcqqrf-libgit2-0.25.1.tar.gz' should have sha256 hash `1cdwcw38frc1wf28x5ppddazv9hywc718j92f3xa3ybzzycyds3s', instead has `0ywcxw1mwd56c8qc14hbx31bf198gxck3nja3laxyglv7l57qp26'

This has been reported before [2].  The workaround suggested there was to download the source directly.  However, this now fails too:

$  guix download
ERROR: Throw to key `gnutls-error' with args `(#<gnutls-error-enum Error while reading file.> set-certificate-credentials-x509-trust-file!)'

I think the error message is a little misleading here.  I have tried to download the same file from a more recent guix installation on another system which also fails.  Essentially, the error is 'file not found'.

So, the situation is that neither a substitute nor the source code are available for libgit2 and Guix gets stuck.  How should one resolve cases such as this?

Best regards,



reply via email to

[Prev in Thread] Current Thread [Next in Thread]