[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot package a PyPI tool

From: Gábor Boskovits
Subject: Re: Cannot package a PyPI tool
Date: Sun, 16 Feb 2020 15:56:28 +0100


<address@hidden> ezt írta (időpont: 2020. febr. 16., Vas 15:31):

> Hello!
> I was playing around with Guix and I tried to package a termtosvg tool
> just for an exercise.
> I have a
> export GUIX_PACKAGE_PATH=~/guix-packages
> setting and I create my *.scm files in that directory.
> my-hello.scm from the documentation worked fine, however when I tried to
> package a more "real-world" example I got an error:
> ------------------------------
> name: python-termtosvg
> version: 1.1.0
> outputs: out
> Backtrace:
>             1 (primitive-load "/home/lain/.config/guix/current/bin/gu…")
> In guix/ui.scm:
>    1824:12  0 (run-guix-command _ . _)
> guix/ui.scm:1824:12: In procedure run-guix-command:
> error: python-lxml: unbound variable
> ------------------------------
> My python-termtosvg.scm content:
> Can I somehow make Guix see python-lxml from the main channel (or maybe
> solve the problem in some other way)?

You should add the package modules providing the inputs into the
define-module form.

I.e. something like (gnu packages python).

You can find out the module of the package using guix package -s
packagename. It reports the location, and file names are mapped to the

I hope that helps.

Best regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]