[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Client fails to find package (mame) with guix publish

From: Efraim Flashner
Subject: Re: Client fails to find package (mame) with guix publish
Date: Tue, 18 Feb 2020 13:40:53 +0200

On Tue, Feb 18, 2020 at 12:31:39PM +0100, Pierre Neidhardt wrote:
> Hi!
> The 'mame' package is not available on for some reason,
> so I did build it locally on my desktop.
> Now I'd like to transfer this build artifact to my laptop.
> On my desktop I ran
> --8<---------------cut here---------------start------------->8---
> sudo guix archive --generate-key
> sudo guix publish 
> --8<---------------cut here---------------end--------------->8---

did you transfer the public key to your other machine and run 'sudo guix
archive --import < /path/to/public/key'?

> Then on my laptop I ran
> --8<---------------cut here---------------start------------->8---
> guix time-machine --commit=a74e231 -- build mame 
> --substitute-urls="";
> --8<---------------cut here---------------end--------------->8---
> The desktop then displays a bunch of
> --8<---------------cut here---------------start------------->8---
> GET /ddjh5vxa692nllffzz92mvyclqv79bkn.narinfo
> GET /j8hk0nv8fn5k5i55z85jhs41x2hvcy5n.narinfo
> ...
> --8<---------------cut here---------------end--------------->8---

I wasn't sure about needing to specify more flags with 'sudo guix
publish' but it looks like it was correct.

> so I guess this means publishing works.
> However my laptop does not fetch the mame substitute and starts building
> mame again, which takes hours.

Try giving it a few minutes to "bake" the substitute and then serve it.
It needs to re-compress it to make transfers (at a large scale) more

> Any idea what's wrong?

Doesn't address the substitute/publish problem, but have you tried using
guix copy to copy it over?

Efraim Flashner   <address@hidden>   אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]